HDMI not getting a signal

We have been watching things through our Chromecast connected to HDMI. Suddenly we have no signals on any HDMI inputs.

HDMI not getting a signal

Posted on 2018-06-17 23:23:15 Signature Vote Up0Vote Down
Current Rating: 0
We have been watching things through our Chromecast connected to HDMI. Suddenly we have no signals on any HDMI inputs. It shows on our input menu, but then it shows no signal...any troubleshooting tips welcome

4 Comments

  • Current Rating: 0
    Reply Title Icon

    RE: HDMI not getting a signal

    Gary_CarrGary_Carr Member
    Posted on 2018-12-13 14:22:05 Vote Up0Vote Down
    Have older model product/Model No. : 55LX9500  3D
    All 4 HDMI inputs stopped working been very happy with it.
    HDMI connector to computer was always intermittent, acted like loose connection.
    Recognizes something connected but no signal.
    Tried all 4 HDMI inputs using Computer. DVD and cable box.
    All other video inputs work OK.
    Maybe be bad connector, bad solder on HDMI chip or bad chip.

    Is it worth fixing?
    Is there local service?
    Is main board available? How much?
    What is equivalent new LG model?






  • Current Rating: 0
    Reply Title Icon

    RE: HDMI not getting a signal

    AlexanderAlexander LG Moderator
    Posted on 2018-11-26 16:23:56 Vote Up0Vote Down
    @judmen, Good day,

    Does this happen on all the HDMI ports? have you tried using a different cable? 

    If that still does not work, then I would recommend having a tech inspect the unit:
    https://www.lg.com/us/support/repair-service/schedule-repair-us
  • Current Rating: 0
    Reply Title Icon

    RE: HDMI not getting a signal

    tapceotapceo Member
    Posted on 2018-06-29 16:17:36 Vote Up0Vote Down
    We've had issues with our HDMI connections. For our situation we have a direct connection via antenna that continues to work just fine. Our HDMI inputs seem to need time to WARM UP like and old old TV. If your young, you won't know what I'm talking about, but in the "old days" we used to turn on the TV and go do something else while it warmed up. Our HDMI seems to "Warm Up" after 5 to 10 minutes and then everything works fine. I have to believe there is an issue with the HDMI "board"? Hope you get yours working. We've been living with this issue for a couple of years now. We're used to it. Good Luck!
  • Current Rating: 0
    Reply Title Icon

    RE: HDMI not getting a signal

    rhalloyrhalloy Member
    Posted on 2018-06-24 17:30:08 Vote Up0Vote Down
    I began having the same problem a week ago.  No signal on all 4 of the hdmi inputs.  Have tried everything including new cables etc.   Any ideas are welcome.
Sign In or Register to comment.