Skip to Content

lg g7- Always defaults to aac and not apt-x when headphone supports it.

so, my issue is with headphones and earbuds that has both aac and apt-x, the lg g7 always defaults to aac.

lg g7- Always defaults to aac and not apt-x when headphone supports it.

Posted on 2018-11-30 16:04:42 Cell Phones Vote Up0Vote Down
so, my issue is with headphones and earbuds that has both aac and apt-x, the lg g7 always defaults to aac. Have to everytime go to developer options to select apt-x manually.

With ldac it works since those have an extra option in their setting to choose best option.

Anyone else got this?

4 Comments

  • Reply Title Icon

    RE: lg g7- Always defaults to aac and not apt-x when headphone supports it.

    AlexanderAlexander LG Moderator
    Posted on 2018-12-05 15:30:56 Vote Up0Vote Down
    @perrioto, Good day,

    Does it do it for all songs? does it matter the codec set up on the song?  have you tried multiple players? what about the player you are using? have you tried to see if there is a default setting to play aptx? 
  • Reply Title Icon

    RE: lg g7- Always defaults to aac and not apt-x when headphone supports it.

    perriotoperrioto Member
    Posted on 2018-12-11 21:05:01 Vote Up0Vote Down
    yes, I have tried different players etc. the g7 selects aac as default when the receiver (headphones etc) has both aac and apt-x codec. If the headphone only has apt-x and the standard sbc, the phone selects apt-x.

    So somewhere in the code of the phone it is set that aac is better than apt-x, when it should be apt-x first then aac and sbc.
  • Reply Title Icon

    RE: lg g7- Always defaults to aac and not apt-x when headphone supports it.

    pvcleavepvcleave Member
    Posted on 2019-08-21 21:10:33 Vote Up0Vote Down
    Has anyone figured out how to fix this? It is the same in my V35. 
  • Reply Title Icon

    RE: lg g7- Always defaults to aac and not apt-x when headphone supports it.

    ciro_defeliceciro_defelice Member
    Posted on 2019-12-01 10:43:43 edited December 2019 Vote Up0Vote Down
    I found a working solution on xda forum: add _NOAAC at the end of your bluetooth device name. Now it connects aptx by default.
    It works on my g7
Sign In or Register to comment.