Skip to Content

LHB 535 home theater stuck on Please Wait

Suddenly yesterday when the unit was turned on to listen to the radio it only showed Please Wait on the little digital display on the unit.

LHB 535 home theater stuck on Please Wait

Posted on 2019-04-17 18:46:29 Home Theater Systems Vote Up0Vote Down

Suddenly yesterday when the unit was turned on to listen to the radio it only showed Please Wait on the little digital display on the unit. The only controls that work are the on/off switch and the sound knob. The unit isn't outputting any video so all the video controls (like reset to factory default) are not available. There is no disk in the player (as with all the other buttons the open disk button doesn't work). The function button also doesn't work so can't select radio (or any other function).

The unit is SIMPLINKed to our smart LG TV. Other than using the radio in the morning it is generally used to play the TV sound through an optical connection to the TV. Two days ago the software notice for the TV update came on and the update was downloaded (but not installed because the TV wasn't turned off for hours) while the TV was SIMPLINKed to the home theater and the home theater was doing sound for the TV. Then the home theater had its problem the next morning. The TV software actually updated later when the TV was turned on that next day and the home theater was I believe off (or at least it wasn't told to do the TV sound). BUT oddly the only function it does still have is TV sound. When the TV is set for optical sound out and Simplink is enabled the home theater plays the sound and the volume can be controlled. The unit comes on when the TV is turned on and goes off when the TV is turned off. There is one change with the TV. The TV always defaulted to its internal speakers and we always needed to go into TV settings and select the optical Simplinked output. Now it skips that step and the home theater comes on with the TV sound shortly after the TV is turned on. The Theater is connected by HDMI to the TV so even though there is no video from the home theater it clearly is getting a some signal through the HDMI connection.

I've tried all the various suggestions. Unplug for a long time, unplug for a short time, hold the on button down when it is plugged back in, wait a long time (hours), turn Simplink off on the TV, turn the power on synchronization off, etc. The only messages other than Please Wait are Good bye, the volume setting, and Simplink enabled.

I'm stumped and don't know if the TV update was just a coincidence or somehow messed up the Theater. The theater software/firmware hasn't been updated for years because as far as I can tell there haven't been any recent updates for this 10 or so year old unit.

1 Comments

  • Reply Title Icon

    RE: LHB 535 home theater stuck on Please Wait

    JamalofLGJamalofLG LG Moderator
    Posted on 2019-04-22 19:45:24 Vote Up0Vote Down

    ctimmerman, the TV updating prior to the malfunctioning of the home theater would have been a coincidence. Only getting the "Please Wait" message would indicate a problem that would require service to resolve. 

    With everything still turning on and playing audio from the TV the problem would seem to be related to the Blu Ray portion of the system.

    Did this resolve your problem? Let everyone know by selecting "Helpful"!

Sign In or Register to comment.