Skip to Content

34GK950F-B firmware or hardware issue?

Just bought a new LG monitor and love it...when it works properly. The issue:

34GK950F-B firmware or hardware issue?

Posted on 2019-06-03 16:22:45 21:9 UltraWide Monitors Vote Up0Vote Down
Just bought a new LG monitor and love it...when it works properly.
The issue: Upon getting the monitor and setting it up for the first time a purple vertical line appeared in the center of the monitor and the colors are way off. I couldn't get rid of it no matter what setting I changed. After going through the monitor menu and settings I saw that the monitor was defaulting back to 6440x1440 for some reason. The only way to get the monitor back to normal is by repeatedly trying to update the firmware and unplug/plug in the power cable. 

Anyone else run into this problem? Is there a solution? Any help would be highly appreciated, I really do like this monitor and I'd hate to return it.
Tagged:

1 Comments

  • Reply Title Icon

    RE: 34GK950F-B firmware or hardware issue?

    NimisumNimisum Member
    Posted on 2019-10-24 12:14:55 Vote Up0Vote Down
    Yeah I've experienced this twice now, got it 2-3 days ago. First time I just unplugged the DisplayPort cable and blew in the socket. After that it worked. The next day I started it from being off all night. Tried the same solution and it didn't work. So I unplugged the power and plugged it in. After that it worked as it should. Did you find a solution or what happened for you?
Sign In or Register to comment.