Skip to Content

Yamaha AVR & LG OLED C8 65" - HELP

Only recently I have bought a new LG OLED C8 65" panel fro my setup. I was using Sony Bravia 40'' LED before along with Yamaha RX-473. I live in India.

Yamaha AVR & LG OLED C8 65" - HELP

Posted on 2019-07-13 07:18:15 TV/Audio/Video Vote Up0Vote Down
Only recently I have bought a new LG OLED C8 65" panel fro my setup. I was using Sony Bravia 40'' LED before along with Yamaha RX-473. I live in India.

My earlier setup was everything plugged into AVR like Popbox Media streamer, amazon firestick & airtel set top box and HDMI out from AVR was connected to my Sony Bravia. The setup was perfect, no problem. I was getting video without any handshake issue.

Yesterday I have bought a new OLED by LG Model C8 65". It has replaced my old sony LED 40". Now I have used the same setup means Firestick, Media Streamer & settop box into AVR and then HDMI out connected to LG OLED. The TV wasn't getting any video Signal from AVR. I tried replacing the cable also & bought a new 4K HDMI ( Good Brand) from the market but still problem persisted. Then I went to Device Coonnect in LG and tried adding Yamaha AVR but still I am not getting any video from AVR to LG OLED. If I connect Firestick & set-top box directly to TV then I am getting video. In fact I played a movie yesterday by directly connecting USB flashdrive to the TV and it played wonderfully.

For time being, I have used optical out from TV to AVR for getting sound but that is not the solution I want. I am not sure what kind of handshake problem I am having with these 2 devices. I request you to please help me out. I have called LG guy but they are quite naive and does not understand working functions of AVR with TV. Your suggestions are highly welcome.

P.S. I have tried all HDMI ports including ARC port. Have also put HDMI control in AVR to "ARC On"

1 Comments

  • Reply Title Icon

    RE: Yamaha AVR & LG OLED C8 65" - HELP

    MartinnovMartinnov Member
    Posted on 2019-08-30 11:50:48 Vote Up0Vote Down
    I have a similar problem. My new 75UK65 does not take input from my NAD 748. Wat's the deal ?
Sign In or Register to comment.