Skip to Content

Oven stopped working properly after first time using the convection bake feature. (Electric)

The day after using the convection bake feature, my husband set the regular bake option to 170 degrees to keep the dinner warm (as we do every night), but the food burned and the oven felt like it was set to 400 degrees instead of only 170 degrees.

Oven stopped working properly after first time using the convection bake feature. (Electric)

Posted on 2019-11-24 15:12:54 Cooking Appliances Vote Up0Vote Down
The day after using the convection bake feature, my husband set the regular bake option to 170 degrees to keep the dinner warm (as we do every night), but the food burned and the oven felt like it was set to 400 degrees instead of only 170 degrees. The oven continued to stay around 400 degrees even after being shut off for more than an hour. We unplugged the range out of fear that it might catch on fire. The next day, we plugged it back in and set it to 170 degrees again. It took a long time to reach temperature, then got much hotter. Later, the same day we set it to 350 degrees. The LED display showed 100 degrees for about 20 minutes before an error message appeared and the oven never got hot. I pressed Clear off to turn off the oven. Prior to using the convection bake option, the oven was working just fine.

1 Comments

  • Reply Title Icon

    RE: Oven stopped working properly after first time using the convection bake feature. (Electric)

    JamalofLGJamalofLG LG Moderator
    Posted on 2019-11-26 17:24:02 Vote Up0Vote Down
    vkent, do you recall the error message that popped up on the display?

    Did this resolve your problem? Let everyone know by selecting "Helpful"!

Sign In or Register to comment.